Respondus Monitor service notice

Incident Report for Respondus

Resolved

The service is now operating normally. The earlier slowdown is being investigated.
Posted Feb 13, 2025 - 11:47 PST

Update

We are continuing to investigate this issue.
Posted Feb 13, 2025 - 11:36 PST

Investigating

We are investigating an issue where some Respondus Monitor users are unable to complete the steps that occur prior to the start of an exam.
Posted Feb 13, 2025 - 11:36 PST
This incident affected: LockDown Browser and Respondus Monitor (webcam).