Respondus Monitor Slowdown

Incident Report for Respondus

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 11:57 PDT

Update

Performance has now returned to normal. The slowdown has been resolved.
Posted Sep 08, 2025 - 11:57 PDT

Investigating

Exams using Respondus Monitor are currently experiencing slow response times. We are investigating the issue and will provide updates as we have them.
Posted Sep 08, 2025 - 11:46 PDT
This incident affected: LockDown Browser and Respondus Monitor (webcam).