Respondus Monitor Service Notice

Incident Report for Respondus

Resolved

Respondus Monitor continues to function normally. No further updates will be provided.
Posted Jun 30, 2026 - 15:02 PDT

Monitoring

The Respondus Monitor service has been restored and should be functioning normally again. We will continue to monitor the service to ensure stability.
Posted Jun 30, 2026 - 13:59 PDT

Investigating

We are currently investigating an intermittent issue with some users being unable to start a Respondus Monitor session. Access to the LockDown Browser Dashboard also appears to be affected. Updates to follow.
Posted Jun 30, 2026 - 13:25 PDT
This incident affected: Respondus Monitor (webcam).