Respondus Monitor LiveChat Service Notice
Incident Report for Respondus
Resolved
The Respondus Monitor LiveChat service is functioning normal now.
Posted Apr 02, 2024 - 14:55 PDT
Investigating
The Respondus Monitor LiveChat service is experiencing an outage. This is not affecting the Respondus Monitor application itself, only the LiveChat help system built into it. The underlying LiveChat technology is from a third party; status and updates on this issue can be followed here: https://status.livechat.com/.
Posted Apr 02, 2024 - 13:11 PDT
This incident affected: Respondus Monitor (webcam).